Questions about LEDs and the OrangeRX R610V2

All things antweight

Moderators: BeligerAnt, petec, administrator

Post Reply
Dazmund
Posts: 36
Joined: Wed Dec 27, 2017 10:38 pm
Location: Deptford, London
Contact:

Questions about LEDs and the OrangeRX R610V2

Post by Dazmund »

Since I'm a dummy who hasn't done electronics since school, I wanted to ask where is the best place in a circuit to put an LED. I'm aware a visible light has to be seen on a competitive robot, hence why I'm going to put them in my circuits now. Also, should it be the right voltage i.e. the same as a 7.4V LiPo? I live near an RS Components so I can get them when needed... unless anyone has good suggestions for LEDs for me to buy?

Also, for one of my new antweights, I bought an OrangeRX R610V2 receiver to connect to a Bristol Bot Builders dual ESC and bound it to a Devo 7e. The problem I'm having is that while forwards and backwards work well enough (plugged into ELEV but runs off of the THRO) I cannot get the drive and steering on the same stick AKA getting it to run on THRO and AILE. Additionally, I cannot get the actual ELEV left stick to work for a servo.

Any help offered will be more than welcome for this peanut!
DAZ DUZ BOTZ

Fili-PA (wedge flipper)
Watta Doze (tank tracked pusher)
Wolfhead (front wheel drive flipper)
2-2 Liftman (fork lifter)
User avatar
Ocracoke
Posts: 111
Joined: Sun Jan 07, 2018 8:14 pm
Location: Somewhere on the Wirral
Contact:

Re: Questions about LEDs and the OrangeRX R610V2

Post by Ocracoke »

If I was to install a LED, I would put it after the switch before the ESC in pararell. For example, from when I built my first AW:

Image

As for the voltage, I think the one in that photo had a resistor built into it so it'd handle 6V (I am using a LiFe battery in that, so it wasn't a big overvolt). I would probably look to get one with a inline resistor to handle around 7 or 8v for a LiPo.
I cannot get the drive and steering on the same stick AKA getting it to run on THRO and AILE.
It needs to be AILE and ELEV based on the page for the ESC? Is mixing already enabled on the Devo 7e? If it is, try disabling it. I had something similar with a Middleweight where I couldn't get the thing to steer at all but turns out I had mixing enabled on the ESC and the receiver. If it isn't, is the yellow wire definitely in the signal pin for the channel?
Team Kaizen

AW: Amai, Ikari, Lafiel, Osu, Ramu
BW: Shu!, The Honey Badger
FW: Azriel
MW: Jibril, Kaizen
User avatar
Kyro
Posts: 407
Joined: Fri Jan 18, 2019 12:36 am

Re: Questions about LEDs and the OrangeRX R610V2

Post by Kyro »

my beetle led light was a set of led's from a poundland cob headlight that i wired into the positive and negative of an old servo lead and plugged it into a spare channel on my rx... worked great for me... the cob ran off of 6v which was funnily enough the same output from the bec built into one of my esc's.

cant help with setting up a devo sadly as i use flysky... if you had one of those i could help with the perfect mixing setup :p
Team Rocket
Esper(4wd flipper)
Mantis (4wd grab 'n' lift)
Dominus (4wd overhead drill bot)
Fennec(4wd flea and 1/2 cluster)
Gizmo (4wd flea and 1/2 cluster)
Dazmund
Posts: 36
Joined: Wed Dec 27, 2017 10:38 pm
Location: Deptford, London
Contact:

Re: Questions about LEDs and the OrangeRX R610V2

Post by Dazmund »

Ah yes, parallel. It's all coming back to me.

I got the terms wrong. ELEV and AILE are on the right, THRO on the left. Forward/backwards works on right stick but not left/right, which only works on RUDD. Also, THRO doesn't work with a servo. I think it looks like a receiver problem as my Devo 7e was just fine with the NanoTwo ESC receiver combo.
DAZ DUZ BOTZ

Fili-PA (wedge flipper)
Watta Doze (tank tracked pusher)
Wolfhead (front wheel drive flipper)
2-2 Liftman (fork lifter)
Post Reply