T_Y's Build Log

All things antweight

Moderators: BeligerAnt, petec, administrator

Post Reply
Matt
Posts: 37
Joined: Sun Jul 01, 2018 6:18 am

Re: T_Y's Build Log

Post by Matt »

Looking forwards to seeing this at robo dojo. Will you be up for "testing" on my new spinner? Hopefully I'll win the balloon fight again. :D

T_Y
Posts: 128
Joined: Thu Mar 15, 2018 12:51 am
Location: York

Re: T_Y's Build Log

Post by T_Y »

Sure, I can fight your spinner! I do need to see if the increased infill is any better than before, or if I need to consider building an enclosure for my 3D printer so I can print in ABS.
Thomas

Ants:
Percussive Maintenance 2: Tech Support Boogaloo
Have You Tried Turning It Off and On Again?
Error 404 - Robot Name Not Found
It's Not a Bug, It's a Feature!
Working As Intended

Matt
Posts: 37
Joined: Sun Jul 01, 2018 6:18 am

Re: T_Y's Build Log

Post by Matt »

Wait till you see it. I am looking forwards to saturday.

T_Y
Posts: 128
Joined: Thu Mar 15, 2018 12:51 am
Location: York

Re: T_Y's Build Log

Post by T_Y »

So I can't make it to AWS 56. Luckily, Robodojo are holding an antweight event the weekend after, so I should have enough time to sort out my bots.

I've spent this afternoon troubleshooting the problems with Percussive Maintenance at the last Robodojo social in September. The gist of it was that my receiver was connected to my transmitter, but for some reason the Arduino was not registering the fact that it was connected. I swapped the LemonRx between Hello, World! and Percussive Maintenance around and still had the same problem so that ruled out a problem there. Tried swapping out some wires to no avail either. I had a spare Arduino lying around so I tried swapping that out, and I got some life back into PM... but it could only move forwards or turn left.

So I did some debugging of the code on the Arduino, it looks like whenever the elevator is down, or the aileron is right, the motor driver is not receiving the signal. I need to sit down and do some more debugging to find what exactly is wrong with it, but I suspect either the motor driver is damaged or the wiring between the Arduino and motor driver is not 100%.

I'm not sure I'll be able to get PM working properly if it is a problem with the motor driver, as I'll need to order a new one, but I've got all the parts lying around for the 4-bar lifter idea I have, so I think I'll try to get that built.
Thomas

Ants:
Percussive Maintenance 2: Tech Support Boogaloo
Have You Tried Turning It Off and On Again?
Error 404 - Robot Name Not Found
It's Not a Bug, It's a Feature!
Working As Intended

T_Y
Posts: 128
Joined: Thu Mar 15, 2018 12:51 am
Location: York

Re: T_Y's Build Log

Post by T_Y »

'Have You tried Turning It off And On Again?' is progressing quite nicely. It's been designed and now I'm printing off the parts and cutting polycarb.

Image

I had to throw away the 4-wheel idea, due to a lack of space (and maybe weight but I never got round to checking that). So it's been driven with 2 wheels at the back.

The back end is flat, so I'm going to add a 'spike' to tilt it back over. My friend had the brilliant idea of theming the spike for HYTTIOAOA (I need a snappier nickname for this bot!)!

Image

The wheels are also a bit of an experiment. I was chatting with people at Robodojo and someone mentioned the possibility of using O-rings as tyres. I'm trying 22x2mm O-rings stretched out to fit a 31mm hub, for a total wheel size of 35mm, with 2 O-rings per wheel.

Image

I also didn't account for the back end of the flipper arm when it flips. It's going to catch the drive motors, so I need to cut off the back end behind the rear pivot. Which will leave a hole in the top at the back as I don't have the time/material to cut a new panel as I still need to finish the construction and wiring.
Thomas

Ants:
Percussive Maintenance 2: Tech Support Boogaloo
Have You Tried Turning It Off and On Again?
Error 404 - Robot Name Not Found
It's Not a Bug, It's a Feature!
Working As Intended

Matt
Posts: 37
Joined: Sun Jul 01, 2018 6:18 am

Re: T_Y's Build Log

Post by Matt »

Will this be ready for next sunday?

T_Y
Posts: 128
Joined: Thu Mar 15, 2018 12:51 am
Location: York

Re: T_Y's Build Log

Post by T_Y »

If everything goes to plan, yes! I'll be bringing all 3 bots (Hello, World!, Percussive Maintenance and HYTTIOAOA) to Sheffield but I'm only entering the two flippers as PM is not combat-ready yet.
Thomas

Ants:
Percussive Maintenance 2: Tech Support Boogaloo
Have You Tried Turning It Off and On Again?
Error 404 - Robot Name Not Found
It's Not a Bug, It's a Feature!
Working As Intended

T_Y
Posts: 128
Joined: Thu Mar 15, 2018 12:51 am
Location: York

Re: T_Y's Build Log

Post by T_Y »

HYTTIOAOA is coming along nicely. I really like how the wheels have turned out. We'll have to see if they're any good!

Image

The shell is cut out and bolted together. I had to do a couple of revisions on the motor stand-offs to make it easy enough to screw them into place. One issue is that I've given myself very little ground clearance - if I lose the ground clearance battle I'm going to be high-centred very quickly and won't be able to drive away. Version 2 I think is going to have the wheels protrude out the back to help with that, maybe also give me a few mm more clearance. Oh, I also need to remove the rear part of the lifting arm so it doesn't collide with the motors.

Image

I've got tomorrow and Saturday to mount the servo and flipper (in the picture above, it's being held up by friction from the sides, which I also need to trim down a bit), sort out the electronics and make sure I've got enough spare parts to put the bots back together!
Thomas

Ants:
Percussive Maintenance 2: Tech Support Boogaloo
Have You Tried Turning It Off and On Again?
Error 404 - Robot Name Not Found
It's Not a Bug, It's a Feature!
Working As Intended

T_Y
Posts: 128
Joined: Thu Mar 15, 2018 12:51 am
Location: York

Re: T_Y's Build Log

Post by T_Y »

So I went to Sheffield last Sunday to take part in a Robodojo/Sheffield Roboteers event, which was incredibly enjoyable!

So the problems started even before the first fight. I brought HYTTIOAOA for its first run, and an hour before the event, I realised it was a few mm too long. That was simple enough to fix, just remove some material off the back. The more pressing concern was that it was 12g overweight! I realised I had made a mistake by printing my wheels at 100% infill... each one was 8.6g! Because of the time constraints, in order to get it under weight i had to remove the read self-righting spike and all the top armour, and cut a hole in the base of the bot! Luckily, there were no axebots there, though there was an overhead grabber. I held the components in with a makeshift lid made of acetate electrical taped to the bot. I'm going to redesign the bot for the next event to reduce its size and weight (spoked wheels and a lower infill for them should solve most of the weight issues by itself).

On to the fights, and I actually won some (my first ever victories)! Both Hello, World! and HYTTIOAOA had 4-5 fights I think, each winning about half of them (I'll have to watch the recordings once they're uploaded to see if I remembered correctly!). I think I'm starting to get the hang of driving antweight bots, as my driving was more controlled than at AWS55 and at Robodojo.

I also got to see some really cool bots. There was an under-cutting spinner that had a 50g bar, which couldn't spin up without the bot itself spinning to give it a kick! Though I think that was because the brushless motor driving it wasn't particularly powerful. Another spinner, in the first fight of the day, exploded spectacularly as the disk caught itself. There was also a pretty effective push bot made from recycled tin cans!

The main tournament was followed by a couple of rumbles. In the first one, HYTTIOAOA managed to last until near the end, where it duelled with Ant-Dino (the aforementioned overhead gripper) for a good few minutes before losing - a proper good scrap.

That was Hello, World!'s last event. I'm retiring it in favour of a new front hinged flipper which looks a bit like Firestorm. Hopefully I'll get it ready for events in January and February. I also need to fix the electronics in Percussive Maintenance, as I'm still excited for that (as ineffective it may be)! It can even self-right now - none of that flailing about like at AWS55!
Thomas

Ants:
Percussive Maintenance 2: Tech Support Boogaloo
Have You Tried Turning It Off and On Again?
Error 404 - Robot Name Not Found
It's Not a Bug, It's a Feature!
Working As Intended

Matt
Posts: 37
Joined: Sun Jul 01, 2018 6:18 am

Re: T_Y's Build Log

Post by Matt »

Hopefully we can have a fight with the robot spinning properly at the next competition.

Post Reply