Devo 7E help?

All things antweight

Moderators: petec, administrator, BeligerAnt

Post Reply
Bad Wolf
Posts: 9
Joined: Fri Jan 05, 2018 5:58 am

Devo 7E help?

Post by Bad Wolf » Thu Jul 26, 2018 2:51 pm

So I’ve finally finished everything on my bot, however I would like to drive my Ant with the left controller and operate the weapon (lifting arm) with the right controller on my Devo 7E. However I’m really not getting it...

I have one Jr plug with only the white cable, I have one Jr plug with Red, Black and White and then I have the JR plug for the servo (brown, red and yellow) which pins should I put these into? :/

ive also out a pic of my screen on the devo 7E, could anyone point me in the right direction for how I need to set this up to work??

https://imgur.com/a/05tlv96

thanks

Bad Wolf

James Bennett
Posts: 7
Joined: Mon Oct 03, 2016 6:45 pm

Re: Devo 7E help?

Post by James Bennett » Sun Jul 29, 2018 9:42 am

This stuff is all set up for model aeroplanes so the channels are all set up in terms of throttle, elevators, ailerons and rudder. On the receiver the pins are labeled so from left to right in your picture they are Binding (Bi), Throttle (Th), Aileron (Ai), Elevator (El), Rudder (Ru), Gear (Ge) and Aux (Al). The pins, from top to bottom in your picture are signal, +ve and -ve, this is also labeled (S+-) on the Rx in case you forget. Fortunately, since the wires carrying all the angry pixies are in the middle, nothing should fry if you plug the leads in backwards. The servo leads are typically coloured white/yellow for signal, red for +ve (angry pixies), black/brown for -ve (calm pixies).

It looks like you have an ESC for your drive motors which is taking power from the battery and outputting (presumably via a BEC) it on the white/red/black lead. The white lead is then taking the second signal for the ESC so it can do left and right as well as forward and back. If that is the case, then I would plug the weapon servo into throttle on the receiver and the other two leads into aileron and elevator. This should allow the robot to move, if it goes in the wrong direction try swapping the leads going to the ESC or flipping the AIL and ELE inputs on the transmitter (you can do that on the screen in your picture). I don't know whether you have mixing on your ESC, if you don't it can be set up on the transmitter.

If your ESC does have a BEC then it is probably outputting 5V, this means that your weapon servo will also be operating on 5V if it gets its power from the receiver. It looks like you are using a 'pink' servo that can run on 7.4V, if that's the case you could connect the servo's +ve and -ve leads to the battery leads (between the power switch and the ESC) instead of to the receiver, to give it more oomph. The LemonRx I have in Plan B is actually rated for 10.2V so I just have everything connected directly to the receiver, I'm not sure whether that would be any simpler with your setup.

I think driving (elevator and aileron) with the left stick and weapon (throttle) on the right stick is 'Mode 1' you can set this in Transmitter menu > Transmitter config.

Good Luck!
Team Risky Biscuit:
Plan B
Vanguard Mk 2

Post Reply