MichaelG92's Build Diaries

All things antweight

Moderators: petec, administrator, BeligerAnt

Post Reply
MichaelG92
Posts: 35
Joined: Sat Apr 14, 2018 8:10 am
Location: Surrey

MichaelG92's Build Diaries

Post by MichaelG92 » Sat Jun 23, 2018 6:16 pm

Now that my exams are finally out of the way, I can begin building. The original plan was to have three weeks to build MicroNewton (a 2wd flipper) and ArmamAnt! (a 4wd pusher) for AWS55 next week, but due to various reasons I've only been able to start building today so it's extremely unlikely both will be ready for next week, so I'm focusing on MicroNewton for now.

On top of that my transmitter hasn't arrived as expected this week, so I can test none of the electronics until it (hopefully!) arrives early next week. So I've only been able to work on the shell today. It's been a frustrating day as I haven't achieved as much as I would've liked; I wanted to be finished but I've had to redrill many holes as I keep getting things out of line. But it's my first build so I will learn from this and get better over time (I hope). It has made me respect all of you far more now I realise how much work goes into even the tiny robots.

The below pictures are the result of a full day's work:
IMG_3986.jpg
IMG_3986.jpg (31.29 KiB) Viewed 561 times
The wheels and motors attached to the base.
Last edited by MichaelG92 on Sat Jun 23, 2018 6:23 pm, edited 1 time in total.
Michael - Team MG Robotics

Fledgling Surrey based roboteering team

MichaelG92
Posts: 35
Joined: Sat Apr 14, 2018 8:10 am
Location: Surrey

Re: MichaelG92's Build Diaries

Post by MichaelG92 » Sat Jun 23, 2018 6:19 pm

IMG_3988.jpg
IMG_3988.jpg (30.88 KiB) Viewed 560 times
The sides attached. I've used 2mm polycarbonate for the sides and flipper blade, 1mm for the brackets and 1.5mm everywhere else.
Michael - Team MG Robotics

Fledgling Surrey based roboteering team

MichaelG92
Posts: 35
Joined: Sat Apr 14, 2018 8:10 am
Location: Surrey

Re: MichaelG92's Build Diaries

Post by MichaelG92 » Sat Jun 23, 2018 6:21 pm

The flipper screwed together, and then resting in place as I haven't had time to make the brackets to screw it in place.
IMG_3990.jpg
IMG_3990.jpg (22.69 KiB) Viewed 558 times
IMG_3991.jpg
IMG_3991.jpg (31.74 KiB) Viewed 558 times
Michael - Team MG Robotics

Fledgling Surrey based roboteering team

Derek Dudge
Posts: 109
Joined: Thu Dec 07, 2017 9:32 pm

Re: MichaelG92's Build Diaries

Post by Derek Dudge » Sun Jun 24, 2018 10:23 am

Looking good!
My robots:

Third Law (antweight) - push/ram bot
Manticore (antweight) - hammer bot

MichaelG92
Posts: 35
Joined: Sat Apr 14, 2018 8:10 am
Location: Surrey

Re: MichaelG92's Build Diaries

Post by MichaelG92 » Sat Jul 07, 2018 6:58 am

After attending AWS 55 and talking to a few roboteers, I've decided to put MicroNewton aside for now until I work out a better way of hinging the flipper, probably via 3D printing. With hindsight it is a slightly complicated design for a first time build, so I'm focusing on something a bit simpler; a 4WD pusher, which will be called ArmamAnt!.

I'm using a Das Mikro 2s6a ESC, and I'm about to start soldering on the wires onto the circuit board. However it's just occurred to me that there are more wires than slots on the circuit board, so I'm unsure what to solder where! I know there is a diagram on what to solder where, so I know what goes where at the top of the circuit board in the picture. It's at the bottom where I'm confused.

Image

Going from left to right, let's label the six slots 1-6. At the moment I'm thinking:

1- JST connector (black wire)
2- JST connector (red wire)
3- both black servo wires
4- both red servo wires
5- white wire servo 1
6- white wire servo 2

Is this correct?
Attachments
IMG_4064.jpg
IMG_4064.jpg (33.65 KiB) Viewed 408 times
Michael - Team MG Robotics

Fledgling Surrey based roboteering team

User avatar
MarkR
Posts: 97
Joined: Mon Dec 18, 2017 12:46 pm
Location: Reading Hackspace
Contact:

Re: MichaelG92's Build Diaries

Post by MarkR » Sat Jul 07, 2018 8:41 am

If they connect to the same RX module, you only need to connect the red/black (5v supply) to ONE servo lead. The other servo lead only needs the white wire (servo pulses signal).

The red/black on the servo lead supply power to the RX. They are internally connected inside the RX anyway, so if you use only a single RX, it's duplication to connect both, and they are low current.

Indeed, soldering two wires on to the tiny, awkward pads on the Dasmikro is not something I would recommend. I used a Dasmikro during development of my robot, Betsie (we were at the AWS55) - but it was toast (like so many others...) long before the event.

In particular, there is very little mechanical strength in the surface pads on the Dasmikro ESC, too much stress on the wires will lift the track and destroy the whole thing.

If you want to make a 4wd, then "daisy chain" the wires to the motors instead of trying to connect two wires to the ESC (or make yourself Y-leads)
Robot: Betsie - RaspberryPi controlled flipper bot with gyro stablisation - too clever for her own good?

MichaelG92
Posts: 35
Joined: Sat Apr 14, 2018 8:10 am
Location: Surrey

Re: MichaelG92's Build Diaries

Post by MichaelG92 » Sat Jul 07, 2018 9:24 am

Hi Mark, I'm not sure what you mean by "same RX module", but if it means am I using one receiver, then yes I am. I'm plugging both servo leads into the same Lemon Rx receiver.

Ok, I think I get what you mean. So I do it like this:

Image

By 'daisy chain the wires to the motors', do you mean connect the second set of motors in parallel, like in this thread?

http://www.robotwars101.org/forum/viewt ... f=1&t=2673
Attachments
IMG_4065.jpg
IMG_4065.jpg (27.88 KiB) Viewed 386 times
Michael - Team MG Robotics

Fledgling Surrey based roboteering team

User avatar
MarkR
Posts: 97
Joined: Mon Dec 18, 2017 12:46 pm
Location: Reading Hackspace
Contact:

Re: MichaelG92's Build Diaries

Post by MarkR » Sat Jul 07, 2018 9:35 am

Yes, that's what I meant.

You only need connect one pair of red/black power wires on the servo leads to the rx (if using only one rx). Using two RXs would be very strange on an antweight, but is not unusual on larger things.

For 4WD - yes connect the motors in parallel. You could make up "Y" shaped leads with the correct lengths on all the legs of the "Y", which is probably nicest - or daisy chain - connect the wire first to one motor, then to the other. But don't try to solder two wires to the Dasmikro.

My robot (Betsie) uses the daisy chain method.
Robot: Betsie - RaspberryPi controlled flipper bot with gyro stablisation - too clever for her own good?

MichaelG92
Posts: 35
Joined: Sat Apr 14, 2018 8:10 am
Location: Surrey

Re: MichaelG92's Build Diaries

Post by MichaelG92 » Sat Jul 07, 2018 9:45 am

I’ll wire them in parallel this time. Thanks Mark, will post a picture later when I’m done.
Michael - Team MG Robotics

Fledgling Surrey based roboteering team

User avatar
MarkR
Posts: 97
Joined: Mon Dec 18, 2017 12:46 pm
Location: Reading Hackspace
Contact:

Re: MichaelG92's Build Diaries

Post by MarkR » Sat Jul 07, 2018 1:47 pm

Just before you solder stuff, check with a meter for short circuit. Occasionally a motor or some other component is a "dead short", it will take much longer to find the fault when you have several in parallel.

My N20 motors measure about 12 ohm on the meter usually (so 2 in parallel should be 6 ohm), if it's less than 1 ohm, it's definitely short.
Robot: Betsie - RaspberryPi controlled flipper bot with gyro stablisation - too clever for her own good?

MichaelG92
Posts: 35
Joined: Sat Apr 14, 2018 8:10 am
Location: Surrey

Re: MichaelG92's Build Diaries

Post by MichaelG92 » Sat Aug 11, 2018 2:29 pm

Hi all, sorry for the radio silence over the past month or so. It turns out my Dad's soldering iron didn't work and I haven't had time to get a new one yet, so building has obviously ground to a halt.

In addition to that I found out about a month ago that I have to resit one of my exams in December, which is obviously disappointing. Passing that's a massive priority so I haven't had and won't have a lot of free time between now and then, so building's going to take a back seat for the rest of the year. If AWS56 does take place in October I'm unlikely to make it.

On the positive side, thanks to a helpful guy on Facebook I've discovered that I can download Fusion 360 for free as a hobbyist. So I've downloaded it and will spend what little free time I have learning how to use it, and will hopefully be able to 3D print some robots late this year/early next. And I'll still be planning builds/ asking questions about parts and feedback on designs.

Until then!
Michael - Team MG Robotics

Fledgling Surrey based roboteering team

Post Reply